Help Articles : Your TinyLetter Account

System requirements for using TinyLetter

TinyLetter is completely browser-based, so there’s no need to download any software to use the application. All of our system requirements will be based on the browser version and settings that are being used.

We recommend using Mozilla Firefox or Google Chrome as your web browser to work in TinyLetter. You’ll need to have cookies and javascript enabled to work in the application, as well as popups to properly view alerts and confirmation windows within the account.

Safari is not fully compatible with TinyLetter, as our app utilizes certain aspects of the HTML5 API that are not supported by Safari and can cause a variety of issues when working in your account. We recommend using one of the above web browsers for the most stable environment. TinyLetter is not compatible with Internet Explorer.